Product
Support
Everything Else
Creating Quick Lists and Quick Entry Forms
macOS

To create a Quick Entry view in macOS, start by creating a new view (Drag a view from the Element Panel, press Shift-CMD-V, choose “New View” from the Icon menu, write an AppleScript to make a new view, etc.) or select an existing view and set its ‘view template’ property to “== None ==”. No matter which way you choose, when you open a view that has no template designated, a Quick Entry view is created automatically.

To create a Quick List view in macOS, you have three choices…

  1. with the view’s ‘view template’ set to == None ==, hold down the Option key and open the view by choosing Open from the Icon menu
  2. with the view open, hold down the Option key and choose == None == from the Inspector popup for the ‘view template’ property.
  3. write an AppleScript to create a Quick List view and run it.

Tip #1: Set the order in which the fields appear on a quick view by clicking on each field in the preferred order before creating the form.

Tip #2: After creating a quick view, you can open the (invisible) underlying template via AppleScript to edit its layout. This one line script will open the template for the frontmost window:
tell application "Helix RADE" to open the view template of the icon of window 1

Classic

There are two methods of creating quick list and entry views.

The first method is to create a new Template, open it, click on the Data rectangle button and select the font (i.e., typeface, size and style) you wish to use for the Fields. Then click on the Label rectangle button and select the font you wish to use for the labels. Select Quick Entry or Quick List from the Edit menu according to the type of form you wish to create. The Template will then contain all the Fields in the Relation. This feature does not recognize inert Fields or calculated defaults, but the Template may then easily be modified as needs arise.

The second method is quicker, if a bit less flexible. Drag out a new View icon and open it in the Form Selection View. If you want to create an entry form, select Clear Form, Find First or Find Last from the View menu (or type command-F, command-1 or command-4). If you want to create a list, select Find All from the View menu. This technique is only available when there are no Templates highlighted in the Template column of Form Selection View. You may attach Queries and Indices to these Views, but neither Templates nor Posts.

If you wish to determine the order in which the Fields appear on the Templates, click on each Field in the order you want them to appear, then use either of the methods described above to create the form.